단어 정렬
시간 제한 |
메모리 제한 |
제출 |
정답 |
맞은 사람 |
정답 비율 |
2 초 |
256 MB |
17873 |
6388 |
4549 |
36.879% |
문제
알파벳 소문자로 이루어진 N개의 단어가 들어오면 아래와 같은 조건에 따라 정렬하는 프로그램을 작성하시오.
- 길이가 짧은 것부터
- 길이가 같으면 사전 순으로
입력
첫째 줄에 단어의 개수 N이 주어진다. (1≤N≤20,000) 둘째 줄부터 N개의 줄에 걸쳐 알파벳 소문자로 이루어진 단어가 한 줄에 하나씩 주어진다. 주어지는 문자열의 길이는 50을 넘지 않는다.
출력
조건에 따라 정렬하여 단어들을 출력한다. 단, 같은 단어가 여러 번 입력된 경우에는 한 번씩만 출력한다.
예제 입력 1
1
2
3
4
5
6
7
8
9
10
11
12
13
14
| 13
but
i
wont
hesitate
no
more
no
more
it
cannot
wait
im
yours
|
예제 출력 1
1
2
3
4
5
6
7
8
9
10
11
| i
im
it
no
but
more
wait
wont
yours
cannot
hesitate
|
풀이
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
| #include <iostream>
#include <vector>
#include <algorithm>
#include <utility>
#include <functional>
#include <map>
using namespace std;
int main(){
vector<pair<int,string>> v; //데이터, 길이
map<string,int> m; //key(data),value(data len)
map<string,int>::iterator iter; //반복자 (접근위해 필요)
int i,n;
cin >> n;
for(i=0;i<n;i++){
string temp;
cin >> temp;
m.insert(make_pair(temp,temp.length()));
}
for(iter=m.begin();iter != m.end();iter++){
v.push_back(make_pair(iter->second, iter->first));
// cout << iter->first << "::" << iter->second << '\n';
}
sort(v.begin(),v.end());
for(i=0;i<v.size();i++){
cout << v[i].second << '\n';
}
}
|