[BOJ]1525 퍼즐

BFS 예제

Posted by kyoungIn on March 14, 2019

퍼즐

시간 제한 메모리 제한 제출 정답 맞은 사람 정답 비율
1 초 32 MB (하단 참고) 6211 2288 1249 34.723%

문제

3*3 표에 다음과 같이 수가 채워져 있다. 오른쪽 아래 가장 끝 칸은 비어 있는 칸이다.

1 2 3
4 5 6
7 8  

어떤 수와 인접해 있는 네 개의 칸 중에 하나가 비어 있으면, 수를 그 칸으로 이동시킬 수가 있다. 물론 표 바깥으로 나가는 경우는 불가능하다. 우리의 목표는 초기 상태가 주어졌을 때, 최소의 이동으로 위와 같은 정리된 상태를 만드는 것이다. 다음의 예를 보자.

1   3
4 2 5
7 8 6
1 2 3
4   5
7 8 6
1 2 3
4 5  
7 8 6
1 2 3
4 5 6
7 8  

가장 윗 상태에서 세 번의 이동을 통해 정리된 상태를 만들 수 있다. 이와 같이 최소 이동 횟수를 구하는 프로그램을 작성하시오.

입력

세 줄에 걸쳐서 표에 채워져 있는 아홉 개의 수가 주어진다. 한 줄에 세 개의 수가 주어지며, 빈 칸은 0으로 나타낸다.

출력

첫째 줄에 최소의 이동 횟수를 출력한다. 이동이 불가능한 경우 -1을 출력한다.

예제 입력 1

1
2
3
1 0 3
4 2 5
7 8 6

예제 출력 1

1
3

예제 입력 2

1
2
3
3 6 0
8 1 2
7 4 5

예제 출력 2

1
-1

내가 추가한 예제

1
2
3
4
5
6
7
8
9
 2 5 7
 8 0 3
 4 1 6
 ->18
 
 6 4 7
 8 5 0
 3 2 1
 ->31

풀이

성찬오빠한테 힌트받고 풀이를 생각해냈다.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
#include <iostream>
#include <vector>
#include <utility>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define p pair<string,int>
#define pp pair<p,int>

string s="";
set<string> chk;
queue<pp> q;
int dir[]={-3,3,-1,1}; //상하좌우
void bfs(){
    
    while(!q.empty()){
        string data = q.front().first.first;
        int cnt= q.front().second;
        int ex= q.front().first.second; //exit -> 0(9)의 위치
        q.pop();
        string puzzle = data;
        for(int i=0;i<4;i++){
            string puzzle = data;
            int nP=ex+dir[i];
            if(nP<0 || nP >8 || (ex==2 && nP==3) ||(ex==3 && nP==2)
               ||(ex==5 && nP==6)||(ex==6 && nP==5)) continue;
            
            int temp=puzzle[nP];
            puzzle[nP]=puzzle[ex];
            puzzle[ex]=temp;
            if(puzzle=="123456789"){
                cout << cnt+1 << '\n';
                return;
            }
            if(chk.find(puzzle)==chk.end()){
                chk.insert(puzzle);
                q.push(pp(p(puzzle,nP),cnt+1));
            }
        }
    }
    cout << -1 << '\n';
    return;
    
    
}
int main(){
    int i,ex;
    for(i=0;i<9;i++){
        int t; cin >> t;
        if(t==0){
            ex =i;
            t=9;
        }
        s+=to_string(t);
    }
    if(s=="123456789")
        cout << 0<< '\n';
    else{
        chk.insert(s);
        q.push(pp(p(s,ex),0));
        bfs();
    }
}